Message Boards

Back

RE: Tutorial 4: Model cannot run unless the well package is removed

Cyntya Rahajeng, modified 2 Months ago.

Tutorial 4: Model cannot run unless the well package is removed

Youngling Posts: 5 Join Date: 1/11/19 Recent Posts

Hi there,

I have a problem in following Tutorial 4 where I got stuck at step number 76. The tutorial says that the simulation ended correctly if the last lines of the .LIST file should look like this:

Run end date and time (yyyy/mm/dd hh:mm:ss): 2018/10/25 11:31:05

Elapsed run time: 4.261 Seconds

However my .LIST file looks like this (attached): DATA IDENTIFIED AS GCD

OPENING FILE ON UNIT   99:

D:\USERS\RAHAJCY\IMOD 4_3\IMOD_USER\DBASE\ISLAND_WELL.IPF

Therefore, I assume that the problem is in the well file so I did not include the well package when choosing the Activate Packages in step 68-69. With this, the model run, but I need to include some wells in the model. Could anyone please help me with this? I have attached the .LIST file and well.IPF file below.

 

Thank you,

Cyntya

Frans Roelofsen, modified 2 Months ago.

RE: Tutorial 4: Model cannot run unless the well package is removed

Padawan Posts: 76 Join Date: 11/11/13 Recent Posts

Hi Cyntya,

We experienced the same issue with Tutorial 4.

An IPF file should be in ascii format.  However, iMOD itself saved the IPF you created in step 51 as a binary file. This gives a conflict while running the model. This issue will be fixed in the next iMOD version.

For now you can use the prepared IPF file that comes with the installation of iMOD. You find the file as D:\USERS\RAHAJCY\IMOD 4_3\tutorials\TUT_Initial_Modeling\WELL.IPF

Kind regards,

Frans

Cyntya Rahajeng, modified 2 Months ago.

RE: Tutorial 4: Model cannot run unless the well package is removed

Youngling Posts: 5 Join Date: 1/11/19 Recent Posts

Hi Frans,

Thank you for your reply. I followed your suggestions right away and the model worked! But how would you suggest if I would use my own points of wells in this kind of model?

My colleague used iMOD version 4.2.1 and he did not have the same error as we had with Tutorial 4. Would it be possible for me to download iMOD version 4.2.1?

Kind regards,

Cyntya

Frans Roelofsen, modified 2 Months ago.

RE: Tutorial 4: Model cannot run unless the well package is removed

Padawan Posts: 76 Join Date: 11/11/13 Recent Posts

Hi Cyntya,

That is correct, version 4.2.1 performs well on this aspect. However, we advise to use version 4.3 while it contains new but also updated/fixed features. If you like to use you r own data to create an IPF file there are at least 2 options:

- 1. You can use iMOD to create the IPF file by hand. To do so, use the option "Edit - create features - create a gen". It has also the option to draw points and save them as an IPF file (see attached screendump)

- 2. If you like to create an IPF file not by hand, use another tool to create the file according to the format requirements described in the manual (chapter "9.7 IPF-files"). I myself prefer to use Excel (save as csv format) or a Python/fortran script.

 

Kind regards,

Frans

Cyntya Rahajeng, modified 2 Months ago.

RE: Tutorial 4: Model cannot run unless the well package is removed

Youngling Posts: 5 Join Date: 1/11/19 Recent Posts

Hi Frans,

Thank you for your suggestions. I would also like to try to use a .csv file to create an .ipf file.

Hope you have a good day!

 

Best,

Cyntya

Cyntya Rahajeng, modified 2 Months ago.

RE: Tutorial 4: Model cannot run unless the well package is removed

Youngling Posts: 5 Join Date: 1/11/19 Recent Posts

Hi Frans,

May I know when will the next version of iMOD be released? Because iMOD is super important to my research time schedule.

Thank you in advance.

Best,

Cyntya

Frans Roelofsen, modified 2 Months ago.

RE: Tutorial 4: Model cannot run unless the well package is removed

Padawan Posts: 76 Join Date: 11/11/13 Recent Posts

Hi Cyntya,

I'm interested in the topic of your research and the way you use iMOD. If you like, please share some of the objectives / approaches (you can use: frans.roelofsen - at- deltares.nl.) 

You ask for the next iMOD release. There is no strict planning yet. As a minimum we release 2 versions a year. The last release (4.3) is dated december 2018. So it will take some more months for the next one.

For the issue we discussed (about the IPF file) we now found an elegant solution by using Create GEN. When transforming your own pointdata into IPF file, the use of Excel is common and recommended. My conclusion is that version 4.3 is still applicable for you research. Do you agree or is there an additional reason to look forward to the release of the new version.

 

Kind regards,

Cyntya Rahajeng, modified 2 Months ago.

RE: Tutorial 4: Model cannot run unless the well package is removed

Youngling Posts: 5 Join Date: 1/11/19 Recent Posts

Hi Frans,

I have sent you an email to frans.roelofsen -at- deltares.nl for a further discussion. Hope we can continue this correspondence via email. Thank you.

Kind regards,

Cyntya