forum

Forum

Here is a list of all currently available discussion groups concerning RTC-Tools.

The discussion groups provide a place for RTC-Tools users to help each other. These discussion groups are in no way a replacement for the RTC-Tools support help desk.

Message Boards

Problem with installation of RTC2 - issues with Python

TK
Tim Kerlin, modified 1 Year ago.

Problem with installation of RTC2 - issues with Python

Youngling Posts: 1 Join Date: 5/11/17 Recent Posts

Dear Guys,

 

So recently I tried to install RTC-Tools but I have some issues installing it.

 

I downloaded the Free-RTC-Tools 2.0 Beta 7 version and tried to install it like shown in getting started (https://rtc-tools.readthedocs.io/en/latest/getting-started.html).

But when I try to install the dependencies I get an error with installing pymoca (no problems with numpy & casadi ). It tells me that I need Python >= 3.5.

 

I have Python 3.7 installed. But I noticed that RTC uses it´s own Python27-folder…

Furthermore I looked for the path variable inside a RTC terminal and inside a usual Windows terminal. The outputs are different. It seems that RTC is either overwriting or not using the default path varable.

 

Maybe someone has an idea how to get it going.


Would be very pleased.
Best regards,
Tim

TV
Tjerk Vreeken, modified 1 Year ago.

RE: Problem with installation of RTC2 - issues with Python

Youngling Posts: 1 Join Date: 12/4/14 Recent Posts

RTC-Tools 2.0 indeed comes with its own environment. We are actually in the process of deprecating 2.0 (and its Python 2 & JModelica dependencies), in favor of RTC-Tools 2.2.

The installation instructions on readthedocs apply to the latter, so installation of 2.2 should be as easy as "pip install rtc-tools rtc-tools-channel-flow". No need to explicitly install casadi/numpy/etc.

As far as Python 3.7 is concerned; CasADi does not have binary wheels available for that version yet (https://pypi.org/project/casadi/3.4.4/#files). So instead I suggest to stick to Python 3.6 for now.