bug message reminder

When adressing a model crash or bug, please remember to include an entire model setup in your post that reproduces the crash or exposes the bug. Also add the XBlog.txt file. This is necessary information for people that are trying to help you. Including your model setup can be achieved by adding the zipped run directory (excluding output) as an attachment to the post.

Forum

Error in configure (rev5052) on linux x64 with Intel Fortran composer 2015

WB
Willem Bodde, modified 2 Years ago.

Error in configure (rev5052) on linux x64 with Intel Fortran composer 2015

Capillary Posts: 6 Join Date: 10/8/14 Recent Posts
Hi all,

I downloaded the trunk from the repository (rev 5052) and I am trying to compile it (unchanged) on linux(x64) using the Intel Fortan composer 2015 with netcdf and mpi.

I follow the steps/commands to issue the configure script as described in Arnold's post:

1
2$ libtoolize --force
3$ aclocal
4$ autoheader
5$ automake --force-missing --add-missing
6$ autoconf
7$ ./configure --with-mpi

When running the configure script it gives an error:

checking for mpif90... mpif90
checking for MPI_Init... no
checking for MPI_Init in -lfmpi... no
checking for MPI_Init in -lmpichf90... no
checking for MPI_Init in -lmpi... no
checking for MPI_Init in -lmpich... no
checking for Fortran flag needed to accept free-form source... unknown
configure: error: Fortran does not accept free-form source

Does anyone know why this error occurs and how to solve it? :-)

If you need more details, please let me know.

Thanks a lot!

Cheers,

Willem
WB
Willem Bodde, modified 2 Years ago.

RE: Error in configure (rev5052) on linux x64 with Intel Fortran composer 2

Capillary Posts: 6 Join Date: 10/8/14 Recent Posts
This issue is resolved. We cleaned up the directory which solved the problem. We did then encounter (and solve) another problem for which I'll make a new post.

Cheers,

Willem
LX
Ludy Xu, modified 1 Year ago.

RE: Error in configure (rev5052) on linux x64 with Intel Fortran composer 2

Capillary Posts: 2 Join Date: 7/12/18 Recent Posts
Willem Bodde:
This issue is resolved. We cleaned up the directory which solved the problem. We did then encounter (and solve) another problem for which I'll make a new post. Cheers, Willem

Hi Willem,

I have the same problem when compiling the source code on my sever (Ubuntu):

checking for openmpif90... no
checking for mpif90... mpif90
checking for MPI_Init... no
checking for MPI_Init in -lfmpi... no
checking for MPI_Init in -lmpichf90... no
checking for MPI_Init in -lmpi... no
checking for MPI_Init in -lmpich... no
checking for Fortran flag needed to accept free-form source... unknown
configure: error: Fortran does not accept free-form source

Can you be a little more specific about how you solve it? I stuck on this problems several days. Thank you very much.

 

 

 

 

WB
Willem Bodde, modified 1 Year ago.

RE: Error in configure (rev5052) on linux x64 with Intel Fortran composer 2

Capillary Posts: 6 Join Date: 10/8/14 Recent Posts

Hi Ludy,

It is quite a while ago, so the exact solution is lost from my memory. In my post I mention that the issue was resolved by cleaning up the directory. This is achieved by running the command 'make clean'. Hope this works for you as well.

Cheers,

Willem