bug message reminder

When adressing a model crash or bug, please remember to include an entire model setup in your post that reproduces the crash or exposes the bug. Also add the XBlog.txt file. This is necessary information for people that are trying to help you. Including your model setup can be achieved by adding the zipped run directory (excluding output) as an attachment to the post.

Forum

Error with: VisualStudio2008 + 2015-10-22_XBeach version

ID
Inaki de santiago, modified 2 Years ago.

Error with: VisualStudio2008 + 2015-10-22_XBeach version

Capillary Posts: 5 Join Date: 4/25/12 Recent Posts
Hi everyone,

In the recent years I have been using the '2012-04-06-XBeach-V19-easter-SOURCE.zip' code without any problem. Everything was perfect.

Now, I would like to migrate to 2015-10-22_XBeach version. Since there isn't any '...SOURCE.zip', I have used TortoiseSVN to download the source code from the repository. Unfortunately, when I click on the 'XBeach_VS2008.sln' nothing happens. I do not even get a message error. I have noticed that if I put the cursor over the visual2008 icon (XBeach_VS2008.sln) a info panel appears which says 'unrecognized version'.

Any suggestion?

Thanks in advance,

Inaki
Arnold van Rooijen, modified 2 Years ago.

RE: Error with: VisualStudio2008 + 2015-10-22_XBeach version

Swell Posts: 239 Join Date: 11/7/11 Recent Posts
Hi Inaki,

If you want to compile XBeach yourself you will need specific software for that (MS Visual Studio 2008 or 2010 and an Intel Fortran Compiler), do you have those installed?

If you are not interested in working with / changing the code itself, I would recommend to just download the pre-compiled executables like you did before for the Easter Release version. You can find newer versions here: https://oss.deltares.nl/web/xbeach/source-code-and-exe (you can find both official releases, for which 'Kingsday' is currently the latest, but you can also download a pre-compiled version of the latest trunk)

Good luck
Arnold
ID
Inaki de santiago, modified 2 Years ago.

RE: Error with: VisualStudio2008 + 2015-10-22_XBeach version

Capillary Posts: 5 Join Date: 4/25/12 Recent Posts
Hi Arnold,

Yes, I do want to modify it. In fact, I would like to pass some tools I made in the '2012-04-06-XBeach-V19-easter' to this '2015-10-22_XBeach' newer version.

INFO:
Windows 10 Home V1703
64 bits, process. x64
VisualStudio2008 v.9.021022.8RTM
Intel(R) Visual Fortran Composer XE 2011

I'll keep you posted

Cheers,

Inaki
ID
Inaki de santiago, modified 2 Years ago.

RE: Error with: VisualStudio2008 + 2015-10-22_XBeach version

Capillary Posts: 5 Join Date: 4/25/12 Recent Posts
Hi all,

I have found the origin of the problem.

If the XBeach_vs2008.sln file is opened with a text editor one would see the following text written in the first two lines:

Microsoft Visual Studio Solution File, Format Version 10.00
# Visual Studio 2010

I have just replace it by:

Microsoft Visual Studio Solution File, Format Version 10.00
# Visual Studio 2008

At the moment I am able to open the project with VisualStudio2008 v.9.021022.8RTM and compile it with no errors. I still need to compare the results with the pre-compiled version though.

Thanks to all,

Inaki