When adressing a model crash or bug, please remember to include an entire model setup in your post that reproduces the crash or exposes the bug. Also add the XBlog.txt file. This is necessary information for people that are trying to help you. Including your model setup can be achieved by adding the zipped run directory (excluding output) as an attachment to the post.

Forum

Back

RE: Matlab toolbox - xb_generate_bathy problem

SH
Scott Hicks, modified 8 Months ago.

Matlab toolbox - xb_generate_bathy problem

Capillary Posts: 5 Join Date: 5/27/17 Recent Posts
Hello,

I am fairly new to XBeach and I am having trouble using the "xb_generate_bathy" command in the openearth toolbox. I am trying to create a bathy file from a small x,y,z data set. I've attached both the dataset and the screen capture of the errors I'm receiving in Matlab (using version 2017b).

Can anyone give me guidance as to what would be causing this error? Does "xb_generate_bathy" require the data in a particular format such as ascending or other particular format?

As a side note: I have previously been working through RGFGRID and QUICKIN to develop my grids and dep files; however, the routines I'm currently attempting to use appear to not be working for grids/dep files created with these tools.

Thanks for any help you can give,
Scott
KN
Kees Nederhoff, modified 5 Months ago.

RE: Matlab toolbox - xb_generate_bathy problem

Wind Posts: 41 Join Date: 3/3/14 Recent Posts
Hi Scott,

If am not sure what is going wrong in your example. It could try 2 things
1. Double check all the dimensions in your matrices.
2. Update / clean-up the OpenEarthTools.

Cheers, Kees
CS
Constantin Schweiger, modified 5 Months ago.

RE: Matlab toolbox - xb_generate_bathy problem

Capillary Posts: 21 Join Date: 1/20/17 Recent Posts
Hi,

just for your information: When I tried to use the toolbox to generate a bathymetry I had the same problem like Scott. Still haven't figured out why... In general, many scripts of the toolbox doesn't work on my computer. Maybe there are some issues with the Matlab Versions? I'm using Version 2015b, for instance.

Best regards,

Constantin