When adressing a model crash or bug, please remember to include an entire model setup in your post that reproduces the crash or exposes the bug. Also add the XBlog.txt file. This is necessary information for people that are trying to help you. Including your model setup can be achieved by adding the zipped run directory (excluding output) as an attachment to the post.

Forum

Back

XBeach-G non-hydrostatic mode in Linux

BP
Benjamin Phillips, modified 4 Months ago.

XBeach-G non-hydrostatic mode in Linux

Capillary Posts: 6 Join Date: 3/1/16 Recent Posts
Hi,

I have compiled XBeach-G from https://svn.oss.deltares.nl/repos/xbeach/tags/2014-03-25-XBeachG-V1/ however when non-hydrostatic mode is enabled (nonh=1 in params.txt) the simulation causes absolutely no erosion. When running the same input files with the Windows executable, or in surfbeat mode on Linux, the simulation runs perfectly fine. Is this likely to be a compilation error? Can I resolve this by using XBeach X Beta with the XBeach-G settings enabled?

Cheers,
Ben