bug message reminder

When adressing a model crash or bug, please remember to include an entire model setup in your post that reproduces the crash or exposes the bug. Also add the XBlog.txt file. This is necessary information for people that are trying to help you. Including your model setup can be achieved by adding the zipped run directory (excluding output) as an attachment to the post.

Forum

RE: MPI for 1D applications

FY
Fateme Yousefi, modified 2 Months ago.

MPI for 1D applications

Capillary Posts: 4 Join Date: 1/23/19 Recent Posts

I have installed XBeach with MPI and ran a 1D application but it seems the model cannot handle 1Ds. The job is not distributed correctly between computer nodes. In fact the nearshore-beach 1D profile is divided into the number of nodes (say 4) but only the first part of the profile is used and repeated 4 times. I even considered different mpiboundary values including auto, but not any success. I have tried XBeach-MPI for 2D applications and it works very well.

Does anybody have any clue?

Fateme 

FY
Fateme Yousefi, modified 1 Month ago.

RE: MPI for 1D applications

Capillary Posts: 4 Join Date: 1/23/19 Recent Posts

I was informed that MPI has been mainly developed for 2D applications, so it is not probably suitable for 1Ds.

Fateme

OM
Oussama Marzouk, modified 1 Month ago.

RE: MPI for 1D applications

Capillary Posts: 9 Join Date: 3/9/19 Recent Posts

Hi Fateme,

 

I've tried MPI for 1D applications, and it worked fine, i guess ?

Maybe the results are not correct but for me it was reasonable. So i don't know why it didn't work out for you.

 

Cheeris

Oussama