bug message reminder

When adressing a model crash or bug, please remember to include an entire model setup in your post that reproduces the crash or exposes the bug. Also add the XBlog.txt file. This is necessary information for people that are trying to help you. Including your model setup can be achieved by adding the zipped run directory (excluding output) as an attachment to the post.

Forum

RE: Problem with generating ouput for variables while using the nonh mode

MU
Michael Ulmgren, modified 2 Years ago.

Problem with generating ouput for variables while using the nonh mode

Capillary Posts: 4 Join Date: 1/19/17 Recent Posts
Hello!
I have built an Xbeach storm surge model and I run simulations with both the surf beat mode (instationary) and the non-hydrostatic mode. From what I can see the non-hydrostatic mode is more stable and can handle my model needs better. One issue I'm having though is that I can't seem to generate output for certain variables while running the non-hydrostatic mode. For example, for a certain project I need output of instantaneous wave height (H), orbital velocity (urms) and bottom shear stress (taubx). However, no data is generated for those variables even though they have been added to the params.txt file as output variables. This issue does not occur when I use the surf beat mode and I'm then able to generate output for any variables.

What is the reason I can't generate output for certain variables while using the non-hydrostatic mode? Is there a workaround solution to this problem?

Thank you for your assistance.

Cheers!

Michael
nicky jassen, modified 16 Days ago.

RE: Problem with generating ouput for variables while using the nonh mode

Capillary Posts: 7 Join Date: 9/16/19 Recent Posts
RE: Problem with generating ouput for variables while using the nonh mode
nicky jassen, modified 8 Days ago.

RE: Problem with generating ouput for variables while using the nonh mode

Capillary Posts: 7 Join Date: 9/16/19 Recent Posts
sigh