bug message reminder

When adressing a model crash or bug, please remember to include an entire model setup in your post that reproduces the crash or exposes the bug. Also add the XBlog.txt file. This is necessary information for people that are trying to help you. Including your model setup can be achieved by adding the zipped run directory (excluding output) as an attachment to the post.

Forum

High velocity jets at model boundary

TD
Tom Dix, modified 4 Years ago.

High velocity jets at model boundary

Capillary Posts: 6 Join Date: 6/5/15 Recent Posts
I have run a model simulation (params file attached) and am seeing high current velocity jets forming at the boundary (images attached). This looks to be a numerical instability in the model. Has anyone experienced this phenomenon before and if so how was it resolved.

Some general information on the model - it was executed for a 24 hour period using two tidal locations and waves defined using instat = 1, with a direction of 260, Hmrs of 1.5 and Tm01 of 2.5. The grid had been created using the matlab toolbox and xb_grid_finalise has been used to extend the lateral and seaward boundaries.
BH
Bas Hoonhout, modified 4 Years ago.

RE: High velocity jets at model boundary

Infra-gravity Posts: 362 Join Date: 5/20/11 Recent Posts
Hi Tom,

Interesting. In the past we had some problems at the offshore boundary with numerical jets.
I recall this had something to do with a bug in MPI, but I'm not sure.
I never saw lateral jets though...

Can you give some additional info, like:
- XBeach version
- offshore water depth
- rest of your model setup
- are you using MPI?

Bas
TD
Tom Dix, modified 4 Years ago.

RE: High velocity jets at model boundary

Capillary Posts: 6 Join Date: 6/5/15 Recent Posts
Hi Bas,

In answer to your questions:

- XBeach version

The exe is from 2013

- offshore water depth

The bathy is extended to -8m using the xb_grid_finalise function with a slope of 1/20. The bathy data used is to about -6m

- rest of your model setup

Anything in particular?

Most of the parameters are configured to default as this is an initial run.
A morfac of 10 has been set.
A sinusoidal tidal pattern has been set based on MHW and MLW measurements and this is input at 2 points on the boundary


- are you using MPI?

Yes MPI was used across 4 cores. The model was also run without MPI for comparison (see file attached) and although this altered the jet pattern being seen it still produced a singular jet, which grows to influence most of the model extent. I have reviewed this jet against the tidal patterns and it appears to be associated with the flood tide.

Any ideas greatly appreciated.

Tom
TD
Tom Dix, modified 4 Years ago.

RE: High velocity jets at model boundary (Answer)

Capillary Posts: 6 Join Date: 6/5/15 Recent Posts
I have now resolved this issue and it was to do with the tidal configuration at my model boundaries!!!